Go Back   FileForums > Game Backup > PC Games > PC Games - CD/DVD Conversions > Conversion Tutorials

Reply
 
Thread Tools Display Modes
  #211  
Old 21-03-2018, 08:26
KaktoR KaktoR is offline
Lame User
 
Join Date: Jan 2012
Location: From outer space
Posts: 2,667
Thanks: 672
Thanked 3,894 Times in 1,403 Posts
KaktoR is on a distinguished road
Yes, it has all of them

PS: You should only enable them in "External Compressor.ini" before compiling.
__________________
Haters gonna hate
RIP GOD

Last edited by KaktoR; 21-03-2018 at 08:29.
Reply With Quote
Sponsored Links
  #212  
Old 21-03-2018, 08:37
vollachr's Avatar
vollachr vollachr is offline
Conversions & UCC Creator
 
Join Date: Sep 2009
Location: Israel
Posts: 250
Thanks: 58
Thanked 515 Times in 184 Posts
vollachr is on a distinguished road
Quote:
Originally Posted by KaktoR View Post
Yes, it has all of them

PS: You should only enable them in "External Compressor.ini" before compiling.
Yeah, noticed that, just, I don't know, maybe I'm missing something, but where's the ExtractSettings in the 2.0.3.9 Setup.ini?

Or how do I tell it which data files to extract?
Reply With Quote
  #213  
Old 21-03-2018, 08:41
KaktoR KaktoR is offline
Lame User
 
Join Date: Jan 2012
Location: From outer space
Posts: 2,667
Thanks: 672
Thanked 3,894 Times in 1,403 Posts
KaktoR is on a distinguished road
2.0.3.9 only using ultraarc (no internal archive handling).

Just create a records.ini
Code:
[Record1]
Type=Freearc_Original
Source={src}\Data1.bin
Output={app}
Disk=1
__________________
Haters gonna hate
RIP GOD
Reply With Quote
The Following User Says Thank You to KaktoR For This Useful Post:
vollachr (22-03-2018)
  #214  
Old 22-03-2018, 02:48
vollachr's Avatar
vollachr vollachr is offline
Conversions & UCC Creator
 
Join Date: Sep 2009
Location: Israel
Posts: 250
Thanks: 58
Thanked 515 Times in 184 Posts
vollachr is on a distinguished road
Quote:
Originally Posted by KaktoR View Post
2.0.3.9 only using ultraarc (no internal archive handling).

Just create a records.ini
Code:
[Record1]
Type=Freearc_Original
Source={src}\Data1.bin
Output={app}
Disk=1
Worked perfectly with 2.0.3.9 and records.ini, so I guess it's CIUv2.0.5g problems.

Unfortunately, I hate using UltraArc and I rather avoid Records.ini file when I possibly can so I'll look into alternative solutions.

At least I now know it's not my compression's fault.
Reply With Quote
  #215  
Old 25-03-2018, 01:40
vollachr's Avatar
vollachr vollachr is offline
Conversions & UCC Creator
 
Join Date: Sep 2009
Location: Israel
Posts: 250
Thanks: 58
Thanked 515 Times in 184 Posts
vollachr is on a distinguished road
Quote:
Originally Posted by Gupta View Post
Editing Ini:
[Tasks]
EditIni1={src}\Codex.ini;Section:Settings;Key:Lang uage;Value:czech;Lang:czech
EditIni2={src}\Codex.ini;Section:Settings;Key:Lang uage;Value:english;Lang:englishUS
EditIni3={src}\Codex.ini;Section:Settings;Key:Lang uage;Value:Default

multiple languages can be separated by ','
EditIni2={src}\Codex.ini;Section:Settings;Key:Lang uage;Value:english;Lang:englishUS,englishUK

above tasks will be performed at ssPostInstall
Can't get the EditIni feature to work...

The ini I need edited is in a sub-folder in the game's installation (Binaries\Win32\), the ini file name is steam_api.ini

The section is [Settings], the key is Language, the available languages are:
English (EnglishUS)
German
French
Italian
Spanish (SpanishES)
Japanese
Korean
Russian

What I tried:

Code:
EditIni1={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:english;Lang:EnglishUS
EditIni2={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:german;Lang:German
EditIni3={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:french;Lang:French
EditIni4={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:italian;Lang:Italian
EditIni5={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:spanish;Lang:SpanishES
EditIni6={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:japanese;Lang:Japanese
EditIni7={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:korean;Lang:Korean
EditIni8={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:russian;Lang:Russian
Also tried the same with {app} instead of {src}

But nothing happens, the value in the ini file remains Language=english, no matter what.

Here's how the ini looks in the relevant section:

Code:
[Settings]

###
### 
### Enter your name here
### 
### Names with diacritic or cyrillic characters are supported but no garantee to work
###

UserName=MYNAME

###
### Select your language here if available
###

Language=english
Any help?

Thanks.

Last edited by vollachr; 25-03-2018 at 01:45.
Reply With Quote
  #216  
Old 25-03-2018, 04:40
Gupta Gupta is offline
Registered User
 
Join Date: Aug 2016
Location: India
Posts: 361
Thanks: 123
Thanked 569 Times in 205 Posts
Gupta is on a distinguished road
Quote:
Originally Posted by vollachr View Post
Can't get the EditIni feature to work...

The ini I need edited is in a sub-folder in the game's installation (Binaries\Win32\), the ini file name is steam_api.ini

The section is [Settings], the key is Language, the available languages are:
English (EnglishUS)
German
French
Italian
Spanish (SpanishES)
Japanese
Korean
Russian

What I tried:

Code:
EditIni1={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:english;Lang:EnglishUS
EditIni2={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:german;Lang:German
EditIni3={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:french;Lang:French
EditIni4={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:italian;Lang:Italian
EditIni5={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:spanish;Lang:SpanishES
EditIni6={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:japanese;Lang:Japanese
EditIni7={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:korean;Lang:Korean
EditIni8={src}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:russian;Lang:Russian
Also tried the same with {app} instead of {src}

But nothing happens, the value in the ini file remains Language=english, no matter what.

Here's how the ini looks in the relevant section:

Code:
[Settings]

###
### 
### Enter your name here
### 
### Names with diacritic or cyrillic characters are supported but no garantee to work
###

UserName=MYNAME

###
### Select your language here if available
###

Language=english
Any help?

Thanks.
Are you changing the language from autorun?
__________________
XD
Reply With Quote
  #217  
Old 25-03-2018, 04:47
vollachr's Avatar
vollachr vollachr is offline
Conversions & UCC Creator
 
Join Date: Sep 2009
Location: Israel
Posts: 250
Thanks: 58
Thanked 515 Times in 184 Posts
vollachr is on a distinguished road
Quote:
Originally Posted by Gupta View Post
Are you changing the language from autorun?
Of course, I tested on German & Italian languages with same result, the ini isn't being changed, it stays with the default English value, even though I selected the correct language on autorun and performed the entire setup in selected language.
Reply With Quote
  #218  
Old 25-03-2018, 06:28
vollachr's Avatar
vollachr vollachr is offline
Conversions & UCC Creator
 
Join Date: Sep 2009
Location: Israel
Posts: 250
Thanks: 58
Thanked 515 Times in 184 Posts
vollachr is on a distinguished road
OK, finally figured the EditIni problem out...

It seems there should be an ending semicolon at the end of each line and it should be with {app}, like this:

Code:
EditIni1={app}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:english;Lang:EnglishUS;
EditIni2={app}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:german;Lang:German;
EditIni3={app}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:french;Lang:French;
EditIni4={app}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:italian;Lang:Italian;
EditIni5={app}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:spanish;Lang:SpanishES;
EditIni6={app}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:japanese;Lang:Japanese;
EditIni7={app}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:korean;Lang:Korean;
EditIni8={app}\Binaries\Win32\steam_api.ini;Section:Settings;Key:Language;Value:russian;Lang:Russian;
That finally worked, at least for the German language, will now test other languages. (Update: Worked for all languages)

It just doesn't work without that last semicolon, my guess is it needs it to "close" the Lang parameter in the line, but I'm no programmer.

Last edited by vollachr; 25-03-2018 at 08:22.
Reply With Quote
The Following 3 Users Say Thank You to vollachr For This Useful Post:
Gupta (09-04-2018), kassane (25-03-2018), pakrat2k2 (25-03-2018)
  #219  
Old 09-04-2018, 08:09
vollachr's Avatar
vollachr vollachr is offline
Conversions & UCC Creator
 
Join Date: Sep 2009
Location: Israel
Posts: 250
Thanks: 58
Thanked 515 Times in 184 Posts
vollachr is on a distinguished road
I'm having a weird problem, I'm creating another of many conversions using the latest Compiler.exe (the one that supports Diskspan - 2.0.5g 180210).

So far, it worked perfectly for every conversion, but this time around I get an error when canceling the installation, see attached image.

I haven't changed any files in the include or include/addon folders compared to any of my other conversions, I'm even using same compression method that worked for most of my conversions so far.

And I can't find anything in Setup.ini that seems to be the reason.

I'd love some help with that, thanks.
Attached Images
File Type: png Error.png (4.4 KB, 127 views)
Reply With Quote
  #220  
Old 09-04-2018, 08:21
Gupta Gupta is offline
Registered User
 
Join Date: Aug 2016
Location: India
Posts: 361
Thanks: 123
Thanked 569 Times in 205 Posts
Gupta is on a distinguished road
you sure you're using correct cls-diskspan.dll

if you sure then send me the files, i'll try debug it...
__________________
XD

Last edited by Gupta; 09-04-2018 at 08:23.
Reply With Quote
  #221  
Old 09-04-2018, 08:24
vollachr's Avatar
vollachr vollachr is offline
Conversions & UCC Creator
 
Join Date: Sep 2009
Location: Israel
Posts: 250
Thanks: 58
Thanked 515 Times in 184 Posts
vollachr is on a distinguished road
Quote:
Originally Posted by Gupta View Post
you sure you're using correct cls-diskspan.dll
Yes, I do, the full uncompressed 1MB cls-diskspan.dll.

I remember having a similar issue before and you told me back then that it was that so I checked to make sure, beside, I have been using the original diskspan dll file ever since.

And I copy the same folder with the same files from conversion to conversion, changing only the design files and setup.ini.

That's why I can't understand it, same files with same simple compression method (m4b+diskspan) worked without a problem before.
Reply With Quote
  #222  
Old 09-04-2018, 08:31
Gupta Gupta is offline
Registered User
 
Join Date: Aug 2016
Location: India
Posts: 361
Thanks: 123
Thanked 569 Times in 205 Posts
Gupta is on a distinguished road
if you sure then send me the files, i'll try debug it...
__________________
XD
Reply With Quote
The Following User Says Thank You to Gupta For This Useful Post:
vollachr (09-04-2018)
  #223  
Old 09-04-2018, 08:33
vollachr's Avatar
vollachr vollachr is offline
Conversions & UCC Creator
 
Join Date: Sep 2009
Location: Israel
Posts: 250
Thanks: 58
Thanked 515 Times in 184 Posts
vollachr is on a distinguished road
Quote:
Originally Posted by Gupta View Post
if you sure then send me the files, i'll try debug it...
I'm uploading the files to my cloud account, I'll PM you when ready.

Thanks.
Reply With Quote
  #224  
Old 09-04-2018, 09:47
pakrat2k2's Avatar
pakrat2k2 pakrat2k2 is offline
Moderator
 
Join Date: Apr 2005
Location: Canada
Posts: 7,238
Thanks: 2,959
Thanked 8,732 Times in 3,042 Posts
pakrat2k2 is on a distinguished road
vollachr, had the same type issue, but not with CIUv2.0.5g, 2039 version. I have a base folder that I used & like you only changed design files & setup.ini, and use over & over again. Couple times for no apparent reason I was getting some kind of corruption, all I had to do was rename the bad setup.ini & copy of a new fresh one. But then DONT copy / paste from old to new, type each line in, & it seemed to fix whatever was causing the issue.
Reply With Quote
  #225  
Old 09-04-2018, 10:25
vollachr's Avatar
vollachr vollachr is offline
Conversions & UCC Creator
 
Join Date: Sep 2009
Location: Israel
Posts: 250
Thanks: 58
Thanked 515 Times in 184 Posts
vollachr is on a distinguished road
Quote:
Originally Posted by pakrat2k2 View Post
vollachr, had the same type issue, but not with CIUv2.0.5g, 2039 version. I have a base folder that I used & like you only changed design files & setup.ini, and use over & over again. Couple times for no apparent reason I was getting some kind of corruption, all I had to do was rename the bad setup.ini & copy of a new fresh one. But then DONT copy / paste from old to new, type each line in, & it seemed to fix whatever was causing the issue.
I'll try that, got nothing to lose.

UPDATE: Nope, didn't help, just did that, I renamed my setup.ini, copied the default CIUv2 Setup.ini file in it's place and manually typed everything into it, same problem.

Weird thing is, I sent Gupta the files and he couldn't re-create my problem, even with my files which had the original Setup.ini.

I can't figure it out, I'm pretty sure it's diskspan related though, I initially though maybe something else in the Addons folder causes it so I left only the diskspan dll file in there and the problem kept occurring. Maybe I'll try to replace the dll file again, might got corrupt or something.

Last edited by vollachr; 10-04-2018 at 01:31.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[CIUv2] Custom Installer Ultimate v2 Project Source Codes KaktoR Conversion Tutorials 606 26-12-2018 07:28
[Wiki] Custom Installer Ultimate v2 KaktoR Conversion Tutorials 34 17-10-2018 08:41
Crysis 3 DVD9 to 3xDVD5 Custom Installer spawniectes PC Games - CD/DVD Conversions 79 31-08-2017 07:19
INDEX - Conversion Tutorial Index Razor12911 Conversion Tutorials 7 01-10-2016 16:28
Tutorial using CI 8.0.0 yener90 Conversion Tutorials 424 21-10-2014 09:49



All times are GMT -7. The time now is 05:00.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2000-2018, FileForums @ https://fileforums.com